Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Hiss / Noise in older electronics normal / fault?

Last updated on 5 months ago
M
Markus
Member
Posted 5 months ago
Thanks for the reply, sent you an e-mail....
Regards,
Markus
pmpm
Junior Member
Posted 5 months ago
Hi Markus,

where are you located in Germany? I´m also German and probably can help you.

KR

PM
Status S2 classic-neck through 4-string headless
Fame MM400
Trace Elliot AH400SM; 1048; 1518
M
Markus
Member
Posted 5 months ago
Hello All!
I recently bought a used Status S1 with the "Series 1"-circuit as shown on the Status Graphite webpage. The bass is lovely, it plays and sounds excellent.
However, the bass introduces quite some noise / hiss which i do not like so much. So i already contacted Rob Green directly. He was so kind to reply, but could not judge from a distance (I live in Germany) if my circuit is damaged or if it is the normal behavior.
So my question is, has anyone of you also experienced hiss in an older circuit? I´m considering to by a new circuit from Status, but if the hiss won´t disappear that would be no good investment, of course.
Thanks for any replies!

P.S: I know, I know, no picture, no bass, so is the picture of my bass visible when included as attachment???
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Moderator: Administrator
Sign In
Not a member yet? Click here to register.
Forgot Password?
Shoutbox
CAPTCHA ImageRefresh Image
Danny
Danny8 days ago
Hey everyone, a bit older but still kicking about!
Jaden25 days ago
I have a 2020 S2 Classic that distorts when I put the bass pot at about 3/4. Batteries are new,
Jaden25 days ago
Does the board 303 EQ have a gain output trim?
andre
andre1 month ago
@thegreek Good point! Will look into it
TheGreek
TheGreek1 month ago
Why are there no dates on any of the thread titles? I can't see when threads were started so no idea if I've read them....frustrating
andre
andre1 month ago
@moo Thank you Sir !!!
moo
moo1 month ago
Happy Birthday to the king of statii
andre
andre2 months ago
@Dabass Cool !
Dabass2 months ago
@andre Works fine now! Just updated my profile with a new password.
andre
andre2 months ago
@Dabass Thanks for letting me know, I have removed Skype for the time being as I cannot make it optional.